Archiv der Kategorie: Wissensdatenbank

Das ist die Oberkategorie, um die Systemkategorien der Wissensdatenbank ordnen zu können.

Atari ST Reparaturtipps

Leblos liegt er da, mehrfaches Ein- und Ausschalten ruft nur eine schwache binäre Reaktion hervor: die LED für die
Betriebsanzeige signalisiert „Strom“, oder eben nicht.

Nach kräftigem Schütteln des Patienten der erste Hoffnungsschimmer, der Monitor wird weiß. Dabei bleibt es leider auch.
Also nochmal aus- und wiedereingeschaltet … nichts. Der letzte zögerliche Kontaktversuch unseres digitalen Kameraden
lässt sich offensichtlich nicht reproduzieren. Wie gut hat es dagegen der Bekannte X getroffen, der hat wenigstens Bomben
auf dem Bildschirm, ‚mal zwei, ‚mal drei und manchmal eine ganze Reihe.

Diese Symptome offensichtlicher Altersschwäche sind in letzter Zeit immer häufiger geworden. Die Ratlosigkeit von
Computerfachhändlern angesichts eines Atari-Rechners weckt nicht gerade Vertrauen in die Kompetenz derselben. Zudem
rechtfertigt der Wiederbeschaffungswert beispielsweise eines 1040 ST von ca. DM 250,- in den seltensten Fällen
dreistellige DM-Aufwendungen für die Reparatur. Also, Ärmel hoch, denn die Axt im Haus …
Um Missverständnissen vorzubeugen:

Schwerwiegende Defekte können auch nach Studium dieses Artikels nicht von Laien behoben werden. Es hat sich jedoch
gezeigt, dass ca. 80% aller Funktionsstörungen sehr einfache Ursachen haben, die meist leicht behoben werden können.
Hier soll gezeigt werden, wie man die eine oder andere Störung mit wenig Aufwand beseitigen kann.
Zur Sache

Hier einige häufige Fehler und deren vermutliche Ursache, in Klammern die Absätze, die man mindestens lesen sollte:

  1. Betriebsanzeige leuchtet nicht > Netzteil defekt (A, B1)
  2. Bildschirm bleibt schwarz > Kontakt /RAM-Fehler (A, C, D)
  3. Bildschirm bleibt weiß > Kontaktfehler (A, C)
  4. Pixelmüll > Kontakt /RAM-Fehler (A, C, D)
  5. Rechner stürzt bei Anfahren der Menüleiste ab (Mega ST) > Blitter (A, E)
  6. Rechner stürzt nach gewisser Zeit ab > Kontakt /RAM-Fehler (A, C, D, Netzteil B2)
  7. Rechner hängt bei Floppyzu griffen > Netzteil (A, B2)
  8. Uhr läuft nicht richtig, Rechner bombt willkürlich > Echtzeituhr (A, F)

Noch ein Hinweis:
Rechner mit diversen Erweiterungen können auch diverse erweiterte Probleme mit sich bringen, auf die hier im Einzelnen
nicht eingegangen wird. Sicher ist aber in jedem Fall, dass eine Hardwareerweiterung, gleich, welcher Art, nur in einem
einwandfrei funktionierenden Rechner richtig arbeitet.

Öffnen des Rechners

Rechner auf den Rücken legen, alle Schrauben lösen und beiseite legen. Wieder umdrehen und Deckel abheben. Beim 260/520
einfach nach oben weg, beim 1040 zuerst an der Seite ohne Floppy, beim Mega ST zuerst hinten und die Leitung zum
Batteriefach abziehen. Es sollte keine Diskette im Laufwerk sein, damit der Auswurfhebel nicht stört.
Beim 260/520er und 1040er die Tastatur abziehen und die drei Schrauben an der vorderen Blechkante lösen. Die Platine des
260/520ers ist noch mit drei weiteren Schrauben befestigt, die man durch Öffnungen im Abschirmblech erreicht, weg damit.
Besitzer eines 1040 müssen die beiden Schrauben mit denen das Netzteil befestigt ist, lösen. Die Platine wird nun mitsamt
Abschirmblechen aus dem Plastikunterteil gehoben.
Ein Mega ST kann in seiner Behausung verbleiben.
Jetzt mit einer Flachzange die Blechlaschen geradegebogen, bei 1040 und Mega ST ist auch eine unter der Floppy, und das
obere Abschirmblech lässt sich abnehmen. Das Netzteil des 1040 ist dabei etwas im Wege, aber es ist zu schaffen.
Das war es, für den Zusammenbau einfach den Text rückwärts lesen.

B1: Das Netzteil

Wenn das Netzteil ausgefallen ist, sollte man sich nach einem Ersatz umsehen. Beim 520er ist der Trafo vergossen und
deshalb unzugänglich, bei 1040 und Mega ST handelt es sich um Schaltnetzteile. Der Fachmann weiß: selbst wenn man ein
defektes Bauelement findet und ersetzt, heißt das noch lange nicht, dass das gute Stück wieder funktioniert. Man kann
bestenfalls die Sicherung überprüfen und bei Defekt ersetzen. Mir ist bisher allerdings noch kein Netzteil untergekommen,
das durch Austausch einer defekten Sicherung wieder zu reaktivieren war, als einziges Ergebnis meiner Bemühungen hatte
ich dann mehrere defekte Sicherungen.

B2:

Die Netzteilspannung sinkt offenbar mit zunehmendem Alter des Rechners ab. Wichtig ist vor allem, dass im 5Volt-Zweig die
Spannung nicht zu niedrig ist.
Die meisten Bauelemente im Atari benötigen eine Spannung von minimal 4,5 V und maximal 5,5 V. Mit einem Handmultimeter
lässt sich das überprüfen. Aber Achtung! Bei Floppyzugriffen sinkt die 5-Volt-Versorgungsspannung um ca. 0.4 Volt ab. Das
bedeutet, das für einen sicheren Betrieb eine Spannung von 4,9 Volt anstehen muss.
Ein zu schlappes Netzteil kann auf folgende Weise getuned werden: man lasse sein Multimeter zur Kontrolle an der
5 Volt-Versorgung hängen und suche ein Poti namens VR1. Wenn man eines gefunden hat, kann man damit die Spannung
abgleichen. Leider läuft der 12 Volt-Zweig auch mit, so dass man zwischendurch auch dort ‚mal die Spannung kontrollieren
muss. Wenn 13 Volt überschritten werden, sollte eine Diode 1N4001 in die 12 Volt Leitung eingeschleift werden. Der
Kathodenring in Richtung Board.
Wer in seinem Netzteil kein Poti findet weil keines da ist, muss parallel zu R14 einen Widerstand von 47K einlöten.

C: Kontaktfehler

Kontaktfehler sind die häufigste Ursache für „seltsame Erscheinungen“. Ob es sich dabei um Oxydation, Verschmutzung oder
ausgeleierte Kontakte handelt ist eigentlich egal, der Effekt ist immer der gleiche.
Bei einem weißen Bildschirm ist zumindest das RAM ansprechbar. Der Fehler ist aller Wahrscheinlichkeit nach bei den Roms
zu suchen. Also, Spucke auf den Daumen und die „Brüder“ kräftig in die Fassungen gedrückt.
Wenn man schon mal dabei ist, sollte man auf ein Nachdrücken der anderen Bauelemente nicht verzichten. Hat diese
fachmännische Aktion keine Früchte getragen, ist man gezwungen sich mit dem GLUE zu befassen. Beschreibung weiter unten.

Bei einem schwarzen Bildschirm sieht die Sache von Vornherein etwas schwieriger aus. in diesem Fall muss man sich mit der
MMU auseinandersetzen. Es handel sich dabei, wie bei dem GLUE, um einen quadratischen Chip mit 68 Pin’s im PLCC-Gehäuse.
Die MMU hört auf den Namen C025912, der GLUE auf C025915. Eventuell vorhandene Klammern über den Chips werden entfernt,
indem mit einem kleinen Schraubendreher eine Seite der Klammer vorsichtig über die Sockelecke gehebelt wird. Wenn kein zusätzliches Blechkreuz über den Sockel gespannt ist und man auch keines zur Hand hat, verzichtet man besser auch auf den Einsatz der Klammern.
Durch die Verspannung des Sockels kann es schon zu Problemen kommen, die Chips fallen auch so nicht heraus. Aber weiter
im Text: sowohl MMU als auch GLUE haben dann und wann unter Kontaktarmut zu leiden. Bei beiden macht es sich am Besten,
sie einmal aus ihrem Sockel zu hebeln und wieder hineinzustopfen.

Normalerweise wird dafür ein PLCC-Ausziehwerkzeug benutzt. Diese hat aber nicht jeder im Hause. Deshalb muss der gute
alte Uhrmacherschraubendreher mit 1mm Klinge einspringen.
Also: Die Klinge in eine der Aussparungen im Sockel stecken und den Chip heraushebeln, das gleiche Spiel diagonal
gegenüber wiederholen.
Jetzt die Anschlüsse kontrollieren, gegebenenfalls wieder geradebiegen und den Chip zurückstecken. Pin 1 ist durch eine
kreisförmige Vertiefung gekennzeichnet.

Wer nun eine Verbesserung/ Veränderung, aber noch keinen sicheren Betrieb feststellt, sollte die Kontakte von MMU und
GLUE mit einer feinen Drahtbürste reinigen, die Kontakte in den Sockeln natürlich auch.
Pixelrnüll hat seinen Ursprung in der Regel in schlechter Verdrahtung oder falscher Einbaulage von Speichererweiterungen.

In jedem Fall müssen die Leitungen so kurz wie möglich sein und an der Zahl der Masse- und +5-Volt-Leitungen sollte man
nicht sparen.
Lässt sich bei den Leitungslängen nichts mehr „herausholen“, kann man durch Einschleifen eines Treibers in die
Steuerleitungen Ras, CasL, CasH und WE die Flankensteilheit so verbessern, dass der Betrieb wieder sicher ist.
Verwendbar ist z.B. ein 74F125. Pin 14 = +5 Volt
Pins 1, 4, 7, 10 und 13 auf Masse Eingang > Ausgang: 2>3,5>6,9>8,12>11.
D: RAM-Fehler, oh Graus…

Schwer zu lokalisieren und genauso schwer zu beheben, deshalb nur ‚was für Atarianer mit Bastelerfahrung. Auch Besitzer
eines 520er ohne Speichererweiterung haben hier schlechte Karten.
Beim Einschalten prüft der Rechner seine RAM-Konfiguration. Er klappert dabei die beiden RAM-Bänke 0 und 1 ab und muss
mindestens auf Bank 0 ein wenig RAM finden, um hochzulaufen. Wenn nun gerade auf Bank 0 ein Speicherchip defekt ist,
bleibt der Bildschirm schwarz, der Atari hat kein RAM.
Hat man zufällig auch die Bank 1 mit RAMs bestückt, wie es im 1040 und Mega ST der Fall ist, kann man die Widerstände der
Steuerleitungen ramseitig auslöten und der jeweils anderen Speicherbank zuordnen. Es ist sehr unwahrscheinlich, dass auf
beiden Bänken ein Chip defekt ist.

Für diese Aktion ist ein Ohmmeter unerläßlich, Lötkolben, etwas Kabel usw. sind ebenfalls Voraussetzung.
Interessant sind die Widerstände mit 68R (blau, grau, schwarz, gold) in der Nähe der RAMs. Sechs sind es an der Zahl und
meist in zwei Gruppen von je drei Stück aufgeteilt. Diese sind alle mit Pins der MMU verbunden, und zwar an folgende:

Pin 6 = Cas0H Pin 7 = Cas0L
Pin 8 = Ras0 Pin 18 = Rast
Pin 21 = Cas1L Pin 22 = Cas1H

Zur Sicherheit von diesen Pins der MMU ausgehend mit dem Ohmmeter die entsprechenden Widerstände lokalisieren.

Alle Widerstände auf der RAM-Seite auslöten oder kurz über der Platine abkneifen. Das nun unbewohnte Lötauge Ras0
ramseitig mit +5 Volt verbinden, dadurch wird die RAM-Bank 0 lahmgelegt. Jetzt die für die Bank 0 vorgesehenen freien
Widerstandsenden mit den freien Lötaugen der Bank 1 verbinden, Ras0-Signal an RastLötauge usw. Wenn der Rechner nun
wieder läuft, hat er natürlich weniger RAM, also die Signale der Bank 1 mit der RAM-Bank 0 verbinden (+5V-Leitung
entfernen) und ‚mal sehen, was passiert.

Aller Wahrscheinlichkeit nach wird der Rechner normal arbeiten und die Speicherbank mit dem defekten Chip nicht erkennen,
aber manchmal hat man Glück. Sollte der Rechner diese Bank akzeptieren, gibt sich der Übeltäter als Pixelfehler auf dem
Bildschirm zu erkennen. Jetzt kann man entweder auf dem Monitor Pixel zählen, oder sich der Holzhammermethode bedienen:
Man nehme eine Meßstrippe und lege eine Seite auf Masse. Dann tippe man mit dem anderen Ende auf den Datenpin eines RAM
der defekten Bank.

Meistens „steht“ der Rechner dann, aber das Monitorbild ist nach wie vor zu sehen. Wenn man mit der Meßspitze nun einen
Datenpin nach dem anderen berührt, sieht man auf dem Monitor senkrechte weiße Linien. Sobald sich diese Linien mit den
Pixelfehlern decken, ist der defekte Chip gefunden.

Datenpins bei X1256 = Pin 2 bei
X11000 = Pin 1 bei
X4256 = Pin's 1, 2, 18, 19.

Wer über ein entsprechendes Testprogramm verfügt, kann sich zumindest den letzten Teil der Arbeit sparen.

E: Der Blitter

Schuld an solchen Boshaftigkeiten ist normalerweise der Blitter. Als Grafikchip für rechteckige Datenschiebereien
zuständig, hat er genau dann seinen ersten Einsatz. Also probehalber erstmal ‚raus damit.
Dazu wie unter C beschrieben das IC aus dem Sockel befreien. Noch ein Tip zur Position: der Blitter liegt zwischen
Mega-Bus und Romport und ist „ein quadratischer Bursche“. Wer jetzt den Rechner einschaltet, wird ein langes Gesicht
machen, weil nichts geht. Geduld bitte…

Da vom Blitter ein Signal weitergereicht wird (was er natürlich nicht mehr tut, wenn er nicht mehr da ist) müssen noch
zwei Lötbrücken geschlossen werden. Eine liegt links vom Mega-Bus und eine ca. 2cm oberhalb.
Wenn das erledigt ist, sollte der Rechner wieder laufen. Nach Einbau eines intakten Blitters das Öffnen der Lötbrücken
nicht vergessen!

F: Das leidige Bomben

Nicht ganz so häufig, aber trotzdem ärgerlich. Schuld ist ein Kondensator: Name C52, Sollwert 100nF.
Im Gegensatz zu den meisten anderen 100nF – Kondensatoren auf der Mega-ST-Platine realisiert dieser, zusammen mit einem
10K-Widerstand, ein Zeitglied. Damit wird verhindert, dass in der Power-Up-Phase irgendwelcher „Kram“ in die
Uhrenregister geschrieben wird. Den Kondensator nun durch einen neuen ersetzen und das war’s mit hoher
Wahrscheinlichkeit.

Ich bin hier bei Weitem nicht auf alle möglichen Fehlerquellen eingegangen, aber für weitergehende Reparaturarbeiten ist
schon eine kostspielige Ausrüstung erforderlich.

Atari ST Floppies

PC Floppy’s sind auf ID=1 eingestellt. Atari ST benötigen ID=0! Dies kann man umstellen (Jumper, Lötbrücke, etc.).

Oft gestellte Frage: Wie bekomme ich die Dateien von meinem Windows-PC auf meinen Atari-ST?

Oft hat der Windows-PC hat Probleme auf dem Atari ST formatierte Disketten zu lesen/schreiben. Die einfachste Lösung ist es die Disketten auf dem Windows-PC zu formatieren! Sollten Sie keine DD-Disketten auftreiben können, nehmen Sie HD-Disketten und kleben Sie das zweite Loch (das ohne Schreibschutz-Schieber) mit Klebeband ab.
Nun muß die Diskette nur noch als DD-Diskette formatiert werden.

MS-DOS / Windows95/98:
In die Kommandozeile/DOS-Shell gehen und formatieren: format /F:720 a:

Windows XP:
Leider kennt der format-Befehl unter Windows XP den obigen Parameter nicht mehr :-( Aber der folgende Aufruf tut dasselbe: format /T:80 /N:9 a:

Hi, die einseitigen Laufwerke gab es nur als Externe Laufwerke SF354..
Diese wurden 1985 mit den ersten 520ST ausgeliefert..

520ST 512kb mit Disk-Tos, im Rom nur ein Loader…
SF354 360k Einseitig…
Monochom Moni…

Gesamt 3000.- DM

kurze Zeit später wurden die ersten SF314 ausgeliefert….

Alle ST mit eingebauten Laufwerken waren dann 720k-Laufwerke…

Disk mit mehr als 720k waren überformatiert…..
Der St hat im Monochrom Modus 35kHz HV und nur dieser Modus funkt am VGA Moni….wenn der Moni 35khz kann…

der Mittlere und Hohe Farbmodus hat nur 15kHz was somit nur Monis mit RGB z.B 1084 funkt und nätürlich am TV welcher auch mit 15Hz funkt.

Fakt ist Farbe nur am TV über HF-Buchse oder mit einem 15kHz RGB Moni…früher gabs mal Multisynch-Monis die schon bei 15khz anfingen.. Die heutigen VGA fangen bei 35kHz oder sogar erst bei 38kHz an….

Mono über Monochrommonitor oder über Adapter mit einen 35kHz VGA Moni…

Atari ST- Geschichte und Modelle

aus Wikipedia

Der Atari ST war ein Heimcomputer von Atari aus dem Jahr 1985. Die ST/TT-Serie eignete sich allerdings auch für professionelle Büroanwendungen. Die Abkürzung „ST“ steht dabei für Sixteen/Thirty-Two (16/32), da der verwendete Hauptprozessor, der Motorola 68000, einen 16 Bit breiten Datenbus hat und intern mit 32 Bit arbeitet. Der Adressbus ist 24 Bit breit.

Geschichte

Der Atari ST war eines der ersten verbreiteten Modelle mit einer grafischen Benutzeroberfläche, dem GEM von Digital Research; der Hauptspeicher lag zwischen 512 kByte und einem MByte, diese Zahl wurde, nach Aufrunden, Teil der Modellbezeichnung (520 ST – 512 KB; 1040 ST – 1024 KB = 1 MB). Einzige Ausnahmen bildeten der 260 ST (wurde mit 512 KB ausgeliefert) und der 520ST+ (1 MB). Der 260 ST sollte getreu seiner Bezeichnung auch nur mit 256 KB ausgeliefert werden. In der Endphase der Entwicklung stellte sich jedoch heraus, daß 256 KB definitiv nicht ausreichen würden, um den Rechner mit TOS sinnvoll zu betreiben. Da jedoch die Werbetrommeln bereits gerührt wurden, wurde er kurzerhand mit 512 KB ausgeliefert. Da er sich sonst kaum vom 520 ST unterschied, verschwand er sehr schnell vom Markt. Zusätzliche Buchstaben gaben weitere Ausstattungsmerkmale an, der 1040 STF besaß etwa ein internes 3,5″-Floppylaufwerk und der 1040 STFM einen TV-Modulator. Anfangs wurde der Atari ST mit dem Betriebssystem auf Diskette ausgeliefert (TOS 1.0), spätere Modelle hatten das Betriebssystem fest im ROM eingebaut. Die Mega ST Serie besaß eine abgesetzte Tastatur und einen Hauptspeicher von bis zu 4 MB. Festplatten waren ebenfalls verfügbar (anfangs 20 MB, MFM) und direkt an den Atari ST anschließbar (DMA-Port, auch ACSI-Port genannt). Der Atari ST besaß die Möglichkeit, entweder einen hochauflösenden Schwarzweiß-Monitor oder einen Farbmonitor mit geringerer Auflösung anzuschließen. Die Farbauflösung betrug 320×200 Pixel bei 16 Farben und 640×200 bei 4 Farben, jeweils aus einer Palette von 512 Farben. Der monochrome Monitor SM124 hatte eine Auflösung von 640×400 Pixeln bei 72 Hz Bildwiederholrate. Dies waren für die damalige Zeit hervorragende Werte, im PC-Sektor gab es gerade CGA, Hercules und für besonders teure Rechner EGA. Daher wurde der Rechner besonders im CAD- oder DTP-Bereich populär. Im deutschsprachigen Raum überwogen auch ansonsten eher Büroanwendungen wie Textverarbeitung oder Tabellenkalkulation. In den USA wurde der ST vorwiegend mit Farbmonitor eingesetzt und galt eher als Spiele- und Demomaschine (siehe: Atari Demos). Weltweit brachte dem Atari ST eine fest eingebaute MIDI-Schnittstelle eine weite Verbreitung bei Musikern und Tonstudios ein. Des Weiteren war der Atari ST sozusagen ein Mittler zwischen den Welten. Das Dateisystem der Disketten war mit dem von MS-DOS weitgehend kompatibel, so dass man beispielsweise Zugriff auf Textdateien hatte, die auf einem PC erstellt wurden. Es gab auch einen Apple-Emulator, und er wurde, mit entsprechender Software versehen, als intelligentes Terminal und Entwicklerstation an verschiedensten Mainframes und Mini-Computern von HP sowie Workstations von Texas Instruments und HP eingesetzt. Der Atari ST stand in Konkurrenz zum etwas später auf den Markt gekommenen Amiga 500 von Commodore. Als Nachfolgemodelle des Atari ST gab es noch den Atari TT, den 1040 STE, den Atari MegaSTE, den Laptop Atari STacy aber auch ein Notebook STBook und ab Anfang der 1990er den Falcon. Letzterer hatte dann aber keinen großen Markterfolg mehr. Mehrere Fachzeitschriften wie ST-Computer, ST-Format, ST-Magazin, TOS, XEST oder Atari Inside versorgten die Nutzer mit Informationen zu diesem Rechner.

Hardware

Modelle

Prozessor: Motorola MC68000, 8 MHz
Arbeitsspeicher: 512 bis 1 MB (max 4 MB über Speichererweiterungen von Drittanbietern möglich),
von dem Speichercontrollerchip „MMU“ verwaltet.
Grafikchip: „Shifter“, benutzte eine Teil des Hauptspeichers als Bildspeicher, wird heutzutage als
„Shared Memory Architektur“ bezeichnet. Auflösungen und Farbtiefen siehe oben
Blitter-Chip: Erst ab 1040STFM, Unterstützung der CPU bei Grafik- und Speicheroperationen.
Nachrüstung über Zusatz-Karten in allen ST-Modellen möglich.
GLUE-Chip: Systemlogik, die das System zusammenhält (Chip-Selects, Takt, etc.)
Sound: Yamaha YM-2149, dreistimmiger Synthesizer-Chip mit Rauschgenerator
Floppy-Controler: WF1772: MFM-Controller für Laufwerke mit Standard-Shugart-Bus.
DMA-Controller: von Atari, steuert die ACSI-Schnittstelle (Atari Computer System Interface) an.
ACSI ist eine auf Gruppe-1-Kommandos und einige Signale eingeschränkte SCSI-Schnittstelle.
2x Motorola 6850: Interface-Bausteine, 1x für die Midischnittstelle, 1x für die serielle Kommunikation mit der
Tastatur
MFP: 68901 MFP (MultiFunctionPeripheral) u.a. für erweiterte Interruptlogik und serielle Schnittstelle
Modell Jahr Merkmal
260 ST 1985 Ur-ST mit Disketten-TOS, nur sehr kurz auf dem Markt
520 ST 1985 Ur-ST mit Disketten-TOS
520 STM 1985 ROM-TOS, TV-Anschluss – wurde später in 520 ST umbenannt
Preis inkl. SF354+SM124 2.000DM (1.020€)
520 ST+ 1985 1 MB RAM
520 STF 1986 internes Diskettenlaufwerk
520 STFM 1986 wie 520 STF, mit TV-Anschluss
1040 STF 1986 wie 520 STF, 1 MB RAM
Preis inkl. SM124 ca. 3.300DM (1.700€)
1040 STFM 1986 wie 1040 STF, mit TV-Anschluss
2080 ST 1986 „Prototyp“ – 2 MB RAM
4160 ST 1986 „Prototyp“ – 4 MB RAM
MEGA ST 1987 abgesetzte Tastatur, 1, 2 oder 4 MB RAM
4160 STE 1988 „Prototyp“ – um Stereo, 2 Joypad-Ports, BLiTTER erweitert
1040 STE 1989 Final Version des 4160 STE, nur 1 statt 4 MB RAM
Preis ca. 1.300DM (660€)
520 STE 1989 Wie 1040 STE, 512 KB RAM
1040 STE+ 1990 Prototyp – 1040 STE mit Festplatte und AT-Emulator
TT 030 1990 68030-CPU/32 MHz, neues TOS 3.0
Mega STE 1991 erweiterter Mega ST im TT-Gehäuse, TOS 2.0x, 16 MHz. Preis für 4MB Version: 2.800DM (1.400€)
FX-1 1991 Falcon-Prototyp mit TOS 2.07
Falcon030 1992 68030-CPU/16 MHz, 56k-DSP, TOS 4.0x, 1040ST-Gehäuse
Preis für 4MB+85MB HDD Version: 2.250DM (1.150€)
Falcon040 1993 „Prototyp“ – Falcon mit 040-CPU
Microbox 1993 „Prototyp“ – Falcon im Desktop-Gehäuse
Tragbare Modelle
Stacy 1989 7,5 kg schwerer Laptop auf Basis des Mega ST
ST Book 1991 Grundfläche eines DIN-A4-Blatts, knapp 2 kg leicht; ca. 1000 gebaute Einheiten
ST Pad 1991 ‚Prototyp‘ – Pentop-Computer

C64 Diagnose: Blank Screen

Ray Carlsen CARLSEN ELECTRONICS… a leader in trailing-edge technology.

Blank screen is the most common symptom, and a failing PLA chip is the most common reason. However, quite a few other failures can cause it as well, such as a bad power supply (check with a known good substitute), bad RAM chip(s), and in general, just about any other chip in there because many chips share multiple data lines. If any one of those lines is loaded down or missing a signal for whatever reason, it can produce that symptom. To narrow it down a bit:

Turn the computer off and back on rapidly about five times. If the screen ever comes up with flashing colors or all one color, the PLA is suspect. Replace it to check. Try a cartridge, such as a game. It essentially „replaces“ some of the chips in the computer when it runs. If a cart works, check the ROMs. The screen may have a normal border even if the CHARacter or BASIC ROMs are bad. A bad Kernal ROM will produce no border.

The internal RF unit outputs a signal that goes to the antenna input of your TV. If the picture is snowy, suspect the RF modulator, assuming the direct video output of the 64 is normal. If the computer is „dead“ but is getting power (red LED on), the modulator will produce a black screen… darker than the blank screen of a failing chip in the computer. A missing 9VAC (power supply problem) is a possiblility. Note that the later C64C will still work without the 9VAC or if the internal fuse opens. However, you will have no sound, the cassette will not work, and the TOD clocks will not work.

See if any of the RAM chips (there are eight of them) get warm or hot… feel each one with the back of your finger after the computer has run for about 5 minutes. Shorted chips will get hotter than the others. Note: bad RAM doesn’t always get hot. See if the computer resets the other components in the system like the drive and/or printer. If so, try a „blind“ disk command and see if the drive responds.. try formatting a disk. If that works, you may have a bad VIC chip (no screen display). Sometimes a bad SID chip will produce a blank screen… pull it out and try the computer. It will run without it, although you will have no sound, and a proportional mouse will not work. The few large chips that normally run hot have a high failure rate: in rough order… the PLA, SID, MPU and the VIC. Static zaps usually take out chips like the CIAs. A shorted CIA can produce a blank screen. Note that you will get the startup screen with the CIA’s removed. You can use that as a diagnostic. The smaller so-called „glue logic“ chips (TTL) run cool and are pretty rugged. Although they rarely fail, I’ve had a few that drove me crazy by making me unsolder a dozen IC’s until I found the bad one. With the above noted exceptions, removing a chip will not allow the computer to produce the startup screen. Removing a chip will in most cases produce a blank screen.

The only practical way to check chips is by substitution. The easiest way to do that is by inserting each suspected chip into a working computer that already has all chips socketed. (You can chase your tail doing it the other way around if you have more than one bad one.) I made a test board for just that purpose. Suspected chip(s) can be tested one at a time and only the bad ones need be replaced. At the very least, you need a source of known good chips for test purposes. Be careful… they are static sensitive. If you don’t want to go to that much trouble to diagnose the problem, you will probably be better off hunting up another C64. Chips are hard to find and expensive. Keep a spare „breadbox“ or two, even if only for parts.

C64 BLANK SCREEN 02-22-99

Rarity Liste

Die Liste darf ich freundlicherweise dank:

Fritz Hohl (hohl@sony.de)

hier zur Verfuegung stellen. Auf http://www.cyberfritz.com/rarity.xls gibt es ggf. die jeweils aktuelle Version.

Die Liste enthält ausgewertete ebay Auktionen und berechnet darauf basierend Durchschnittspreise und Seltenheitsgrade von historischen Computern.

PDF Ausdruck der Tabellenseite 2 mit Durchschnittspreis und Marktgeschehen (Stand 21.12.2011)

Vollständige Excel-Liste mit allen Einzelheiten

C64 Diagnose: 1540 und 1541

1540 / 1541 Service Manual

From: Ray Carlsen CET

1541 CHIPS VS SYMPTOMS latest additions or corrections: 2-15-08
This list represents the most common versions of the 1541 in the standard brown case with PC board numbers 1540050 (early ALPSpush-down door mechanism) and the 251830 and 251777 (Newtronics twist door mechanism). Although the very early „long board“ (white case) 1541 is not represented here, major chip functions are of course similar. Thatdrive used more TTL (so-called „glue logic“) chips that were later „integrated“ into a single motor control IC. Although functionally identical, newer drives such as the 1541C and 1541-II integrate more functions into fewer more specialized IC’s, making some repair parts even harder to find. Although most of the chips in the different versions of the standard brown case 1541 are the same, board layout and some chip ID numbers may be different. To eliminate confusion, I will list the two major versions of the drive separately. In another article (fix1541.txt) I will give you some troubleshooting tips. Included is how the drive should behave during normal operation and what is likely to cause a particular fault. Before suspecting any IC chips, don’t overlook more common causes of problems such as a dirty read/write head. Always check the „easy stuff“ first.

1541 CHIPS VS SYMPTOMS PCB# 1540050 (early version) with ALPS drive mechanism (1982)

UA1 74LS14 LOGIC

Partial failure common cause of „FILE NOT FOUND“ error. Total failure: when drive powered up, red LED stays on and spindle motor runs continuously (check also UB4, UC2, UC4, UC5, UC6, UD3, and UD5).

UB1 7406 (M53206P) LOGIC

Partial failure most common causing „SEARCHING FOR“ (also check UC3), or „DEVICE NOT PRESENT“. Total failure: drive may power up normally, but will not reset when the computer is turned on.

UB2 TMM2016AP-10 16K RAM TMM2116AP-15 or MB8128-15

When drive powered up, motor runs continuously and red LED flashes slowly (about 1 flash every 2 seconds).

UB3 325302-01 DOS ROM

When drive powered up, red LED flashes 3 times repeatedly.

UB4 901229-03 or -05 DOS ROM

When drive powered up, red LED stays on and spindle motor runs continuously. DOS ROM is a common failure. Check also UA1, UC2, UC4, UC5, UC6, UD3, and UD5.

UC1 325572-01 MOTOR CONTROLLER

When drive powered up, red LED comes on and goes out, but spindle motor does not turn. When LOAD attempted, spindle does not turn, red LED flickers, screen displays „FILE NOT FOUND“ and red LED flashes.

UC2 6522 VIA (MOTOR CONTROL INTERFACE)

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC4, UC5, UC6, UD3, and UD5.

UC3 6522 VIA (SERIAL INTERFACE)

Drive powers up and resets normally. When LOAD attempted, screen indicates „SEARCHING FOR …“, but no motors run and red LED does not light.

UC4 6502 MPU

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC5, UC6, UD3, and UD5.

UC5 74LS04 (74LS14) LOGIC

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC4, UC6, UD3, and UD5.

UC6 74LS00 LOGIC

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC4, UC5, UD3, and UD5.

UC7 74LS42P LOGIC (DECODER)

When drive powered up, motor runs continuously and red LED flashes slowly (about 1 flash every 2 seconds). Red LED may stay on and/or motor may stop.

UD1 7406 (M53206P) LOGIC

When drive powered up or reset, spindle motor runs momentarily, but red LED doesn’t come on. When LOAD attempted, screen indicates „SEARCHING FOR …“ but red LED does not light, spindle runs continuously, and screen shows „FILE NOT FOUND“ error.

UD2 7417 LOGIC (R/W CONTROL BUFFER)

When drive powered up or reset, red LED comes on and goes out, but spindle motor does not turn. If LOAD is attempted, red LED comes on, stepper moves slightly, spindle doesn’t turn, screen shows „FILE NOT FOUND“ and red LED flashes.

UD3 74LS86 LOGIC

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC4, UC5, UC6, and UD5.

UD4 9602 (8602) LOGIC (MMV)

Drive powers up and resets normally, but if LOAD is attempted, spindle motor runs with red LED out. Screen displays „SEARCHING FOR …“ and stepper does not move. Check also UE6.

UD5 74LS197 (74177) LOGIC (TIMER)

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC4, UC5, UC6, and UD3.

UE4 LM311 COMPARITOR (READ LOGIC)

Powers up normally. When LOAD attempted, spindle turns and red LED comes on, but „FILE NOT FOUND“ and red LED flashes. Check also UF3 and UF4.

UE6 74LS193 (7417) LOGIC (BIN COUNTER)

Drive powers up and resets normally, but if LOAD is attempted, spindle motor runs with red LED out. Screen displays „SEARCHING FOR …“ and stepper does not move. Check also UD4.

UF3 NE592N READ PREAMPLIFIER

Powers up normally. When LOAD attempted, spindle runs and red LED comes on, but „FILE NOT FOUND“ and red LED flashes. Check also UE4 and UF4.

UF4 NE592N READ AMPLIFIER

Powers up normally. When LOAD attempted, spindle runs and red LED comes on, but „FILE NOT FOUND“ and red LED flashes. Check also UE4 and UF3.

VR1 UA7812KC (LM340KC-12) +12 VOLT REGULATOR

Drive powers up „normally“, but motors run slowly or not at all. If that happens, drive access will produce a flashing red activity LED and errors „file not found“ or „drive not ready“ on the error channel.

VR2 UA7805KC (LM340KC-5.0) +5 VOLT REGULATOR

Green (power) LED dim, flickers, or does not come on at all, but spindle may run continuously and red LED may be dark.

CR1 2 AMP 200V BRIDGE RECTIFIER (FOR +12V)

Drive appears to power up normally, but motors do not run. Should get warm only if the drive is being accessed (motors running).

CR3 2 AMP 200V BRIDGE RECTIFIER (FOR +5V)

On power up, green and red LED’s are dim or dark and spindle motor runs continuously. May be intermittant and „die“ after warmup. Part runs very hot normally and is a common failure in this model.

1541 CHIPS VS SYMPTOMS PCB# 251830 or 251777 with Newtronics drive mechanism (1984)

UA1 74LS14 LOGIC

Partial failure common cause of „FILE NOT FOUND“ error. Total failure: when drive powered up, red LED stays on and spindle motor runs continuously (check also UB4, UC2, UC4, UC6, UC7, UD3, and UD5).

UB1 7406 (M53206P or 7707) LOGIC

Partial failure common cause of „SEARCHING FOR“ (check also UC3) and „DEVICE NOT PRESENT“ errors. Total failure: drive powers up OK, but does not respond to computer… no reset or disk access.

UB2 TMM2016AP-10 16K RAM TMM2116AP-15 or MB8128-15

When drive powered up, spindle motor runs continuously and red LED flashes about once every two seconds.

UB3 325302-01 DOS ROM

When drive powered up, red LED flashes 3 times repeatedly.

UB4 901229-03 or -05 DOS ROM

When drive powered up, red LED stays on and spindle motor runs continuously. DOS ROM is a common failure. Check also UA1, UC2, UC4, UC6, UC7, UD3, and UD5.

UC1 325572-01 MOTOR CONTROLLER

When drive powered up or reset, red LED comes on and goes out, but spindle motor does not turn. When LOAD attempted, spindle does not turn, red LED flickers, screen displays „FILE NOT FOUND“ and red LED flashes.

UC2 6522 VIA (MOTOR CONTROL INTERFACE)

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC4, UC6, UC7, UD3, and UD5.

UC3 6522 VIA (SERIAL INTERFACE)

Drive powers up and resets normally. When LOAD is attempted, screen indicates „SEARCHING FOR …“, but no motors run and red LED does not light.

UC4 6502 MPU

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC6, UC7, UD3, and UD5.

UC6 74LS04 (7713) LOGIC

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC4, UC7, UD3, and UD5.

UC7 74LS00 LOGIC

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC4, UC6, UD3, and UD5.

UC8 74LS42 LOGIC

When drive powered up, spindle motor runs continuously. Red LED may stay on, or flash three times and go out.

UD1 7406 (M53206P) LOGIC

When powered up, spindle motor runs momentarily, but red LED doesn’t come on. When LOAD attempted, screen indicates „SEARCHING FOR …“ but red LED does not light and spindle runs continuously.

UD2 7407 (7417) LOGIC (R/W CONTROL BUFFER)

When drive is powered up or reset from computer, red LED comes on and goes out, but spindle motor does not turn. When LOAD is attempted, stepper moves slightly, spindle doesn’t turn, and error message on screen is „FILE NOT FOUND“ with flashing red LED.

UD3 74LS86 LOGIC

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC4, UC6, UC7, and UD5.

UD4 9602 (74123) LOGIC (MMV)

Drive powers up and resets normally, but when LOAD is attempted, screen indicates „SEARCHING FOR …“ red LED does not light and spindle runs continuously. Check also UE6.

UD5 74LS197 (74177) LOGIC (TIMER)

When drive powered up, red LED stays on and spindle motor runs continuously. Check also UA1, UB4, UC2, UC4, UC6, UC7, and UD3.

UE4 LM311 COMPARITOR (READ)

Drive powers up and resets normally. Spindle motor runs, stepper moves slightly, but „FILE NOT FOUND“ error, and red LED flashes. Check also UF3 and UF4.

UE6 74LS193 (7417 or 7407) LOGIC (COUNTER)

Drive powers up and resets normally, but when LOAD is attempted, screen indicates „SEARCHING FOR …“ red LED does not light and spindle runs continuously. Check also UD4.

UF3 NE592N (LM592) READ PREAMP

Drive powers up and resets normally. Spindle motor runs, stepper moves slightly, but „FILE NOT FOUND“ error and red LED flashes. Check also UF4 and UE4.

UF4 NE592N (LM592) READ AMPLIFIER

Drive powers up and resets normally. Spindle motor runs, stepper moves slightly, but „FILE NOT FOUND“ error and red LED flashes. Check also UF3 and UE4.

VR1 UA7812KC (LM340KC-12) +12 VOLT REGULATOR

When powered up, green power LED comes on and red LED comes on and goes out normally, but motors do not run (or move slowly). Drive access will produce a flashing red activity LED and error messages „file not found“ or „drive not ready“ on the error channel.

VR2 UA7805KC (LM340KC-5.0) +5 VOLT REGULATOR

Green (power) LED dim, flickers, or does not come on at all. Drive appears dead, but spindle motor runs continuously.

CR1 2 AMP 200V BRIDGE RECTIFIER (FOR +5V)

Drive appears dead, but spindle motor runs continuously with both green and red LEDs dim or dark. May be intermittant and fail after warmup. This part normally runs hot and is a common failure item.

CR3 2 AMP 200V BRIDGE RECTIFIER (FOR +12V)

Drive appears to power up normally, but motors do not run. Should get warm only if drive is accessed (motors running).

Notes: UC2, UC3, UB4, and regulators VR1 and VR2 run warm normally and bridge rectifiers CR1 and CR3 run very hot if drive is being accessed. Otherwise, only CR3 will get hot.

Newtronics drives (twist type door latch) normally run a bit noiser (stepper chatter) than earlier ALPS (push down door) types.

Ray Carlsen CET CARLSEN ELECTRONICS… a leader in trailing-edge technology. Questions and comments are welcome, especially if you spot a mistake here. Thanks!

Standard Elektrik Lorenz AG / ITT

Die Standard Elektrik Lorenz AG (heute Alcatel-Lucent Deutschland AG) ist ein Unternehmen der Nachrichtentechnik (früherer Slogan: SEL – Die ganze Nachrichtentechnik) mit Hauptsitz in Stuttgart. Zur Nachrichtentechnik zählen auch Informations- und Kommunikationstechnik, Telekommunikationstechnik (SEL war für die Röchelschaltung bekannt) und früher Fernmeldetechnik oder Schwachstromtechnik. Einen weiteren Geschäftsbereich hatte das Unternehmen in der Bahnsicherungstechnik, so wurden für die Deutsche Bundesbahn Relaisstellwerke und elektronische Stellwerke mit den dazugehörigen Außenanlagen (Signale, Gleisfreimeldeanlagen, Weichenantriebe) sowie die Linienzugbeeinflussung entwickelt und gebaut, welche auch bei ausländischen Bahnen Abnehmer fanden. Der Bereich gehört seit 2007 als Thales Transportation Systems GmbH (seit 02.2011 vorher Thales Rail Signalling Solutions GmbH) zum Thales-Konzern. Die bereits 1998 ausgegliederten Bereiche Alcatel Air Navigation Systems und SEL Verteidigungssysteme sind ebenfalls heute in Thales Deutschland beheimatet.

ITT 3030

Extern entwickelt durch die Ettlinger Firma Steinmetz-Kritschke-Systemtechnik wurde der ITT 3030 von Standard Elektrik Lorenz (SEL) vertrieben. Auch die Fertigung erfolgte extern.